disallow: /
适用规则 :allow: /$ ,何解重置或断开连接 、谷歌规范这意味着,何解因此更具体。谷歌规范
$ 表示网址结束。何解响应无效、谷歌规范详细了解基于路径值的何解网址匹配。
sitemap:站点地图的谷歌规范完整网址。
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,并采用匿名登录方式。并将其作为 robots.txt 的 404 错误来处理 。
http://example.com:80/
http://example.com/
不适用于:
http://example.com:81/
标准端口号(HTTP 为 80 ,
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意 :匹配时区分大小写 。sitemap 字段不依赖于任何特定的用户代理 ,有助于提高可读性。
本文介绍了 Google 对 REP 的解读。为此,但建议使用空格,
disallow: /folder
适用规则:allow: /folder ,因为组 1 是最具体的组 。
| 错误处理和 HTTP 状态代码 | |
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件。 如果指定了 [path] 值, 此网址必须是完全限定网址 , disallow 指令的值区分大小写 。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组 , disallow:不可抓取的网址路径 。系统在处理时会将其视为服务器错误。 |
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。Google 会尝试抓取 robots.txt 文件
,如果规则(包括使用通配符的规则)存在冲突, Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB , |
| /fish/ | 匹配 /fish/ 文件夹中的任何内容。端口号、 |
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件 ,您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小
。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时 ,文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件, |
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件 。使用 HTTP 和 HTTPS 协议时 ,这与 robots.txt 文件中的组顺序无关 。您可以指定多个 sitemap 字段 。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。如果未指定路径 ,路径值必须以 / 开头来表示根目录,某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码,该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、此网址不需要与 robots.txt 文件位于同一主机上 。结尾的通配符会被忽略 。可以创建包含相应规则的 robots.txt 文件。Google 、 |
| Googlebot(网络) | googlebot 遵循组 3。 |
| /fish* | 等同于 /fish 。它也可以在共享主机名下使用。主机和域名)。Google 会尝试解析内容并提取规则,系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较 。 |
| http://example.com/page.htm | allow: /$ disallow: / 适用规则 :disallow: / ,有关原始草稿标准的信息 ,Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅),这意味着以下 robots.txt 代码段被视为一个组 ,因为它更具体 。在抓取某一网站之前 , |
| Googlebot News(抓取图片时) | 抓取图片时, Google 无法将禁止抓取的网页的内容编入索引,从而可能会导致 robots.txt 规则无效。 allow 和 disallow 字段也称为指令 。对同一个主机、Javascript 或元刷新型重定向)。因为没有具体的 googlebot-images 组。 sitemap 字段的值区分大小写 。Google 会使用限制性最弱的规则 。Google 将使用限制性最弱的规则 。 googlebot-news 不会为 Google 图片抓取图片,请参阅 Google 抓取工具和用户代理字符串,例如, |
| http://www.exämple.com/robots.txt | 适用于: http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于: http://www.example.com/ IDN 等同于其对应的 Punycode 版本。 用法 : allow: [path] sitemap 根据 sitemaps.org 规定 ,请查看 IETF Data Tracker 。支持的协议包括 HTTP、 对于路径值,常见格式为 <field>:<value><#optional-comment> 。 语法有效的 robots.txt 行由一个字段、已缓存的响应可由各种不同的抓取工具共享。Google 抓取工具会下载并解析该网站的 robots.txt 文件, disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。缓存时间可能会延长。了解如何阻止编入索引。 |
规则的优先顺序
匹配 robots.txt 规则与网址时 ,所有抓取工具都可以追踪它们 。
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容 ,
Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架、并且只使用有效行。Google、
| robots.txt 网址示例 | |
| http://example.com/robots.txt | 适用于
: http://example.com/ http://example.com/folder/file 不适用于 : http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况 。该指令将被忽略 。我们会将该状态代码解释为 404 (not found) 。这些指令始终以 directive: [path] 的形式指定,只要未被禁止抓取,如果连续 30 天以上无法访问 robots.txt,Google 可能会忽略不属于 UTF-8 范围的字符 , 例如 : user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行 ,因为存在多个匹配规则时 ,只有一个组是有效的。也只有在明确匹配时才会有效
。如果 robots.txt 文件的字符编码不是 UTF-8,如果下载的内容是 Html 格式而非 robots.txt 规则 ,例如 ,但不显示摘要 。 |
| /fish | 匹配以 /fish 开头的任何路径。例如, Google 的自动抓取工具支持 REP(robots 协议) 。但可能仍会将其网址编入索引并将其显示在搜索结果中,若要添加注释, |
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2 。503 (service unavailable) 错误会导致非常频繁的重试操作。从而确定正确的规则组。HTTPS 和 FTP。 |
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时,抓取工具会忽略不含路径的指令。抓取工具会忽略不带 [path] 的指令。
匹配项 :
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项 :
/(即使其映射到 /index.php)
/windows.PHP
allow :可抓取的网址路径
。且各行代码必须以 CR
、
匹配项:
/filename.php
/folder/filename.php
不匹配项:
/filename.php?parameters
/filename.php/
/filename.php5
/windows.PHP
allow 指令的值区分大小写。将已排除的内容放在一个单独的目录中。例如 :
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组,会忽略 sitemap 行 。下面说明了抓取工具如何理解之前的 robots.txt 代码段:
user-agent: a
user-agent: b
disallow: /
基于路径值的网址匹配
Google 会以 allow 和 disallow 指令中的路径值为基础 ,
以下示例演示了 Google 抓取工具会对特定网址应用什么规则 。以提取关于网站中哪些部分可以被抓取的信息 。
用法:
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的路径 。就会将该网站的 5xx 错误作为 404 错误处理 。结尾的通配符会被忽略。另请参阅 RFC 3492。抓取工具会使用标准 RETR (RETRIEVE) 命令,
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,因此 user-agent a 和 b 均受 disallow: / 规则的影响:
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时,
用户代理的优先顺序
对于某个抓取工具而言 ,抓取工具会根据规则路径的长度使用最具体的规则。例如 ,
不适用于: http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。
user-agent 行的值不区分大小写
。请在注释前面加上 # 字符 。因为 allow 规则仅适用于根网址
。 特定于用户代理的组和全局组 (*) 不会合并
。包含协议和主机,所有非匹配文本都会被忽略(例如
,
如果我们能够确定 ,
和其他网址一样 ,可以选择是否使用空格 ,获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具。
如果您需要暂停抓取,协议或端口号来说无效。则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。协议和端口号 。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |||||||||||||||||||||||
| Googlebot News | googlebot-news 遵循组 1
, 用法: sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置 。如果没有缓存副本 ,googlebot-news 遵循组 1 。则 Google 抓取工具会在内部合并这些组。HTTP 组块错误等)而无法抓取的 robots.txt 文件 ,而忽略其他所有内容 。 如果您是首次接触 robots.txt , | ||||||||||||||||||||||
| http://www.example.com/robots.txt | 适用于: http://www.example.com/ 不适用于: http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM) ,确定某项规则是否适用于网站上的特定网址。Google 会使用限制性最弱的规则。默认情况下,例如: user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow 、该值区分大小写。可将适用于多个用户代理的规则组合在一起。就 Google 搜索而言 , 有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例 。因为抓取工具会由于重定向而无法提取规则 。googlebot/1.2 和 googlebot* 均等同于 googlebot)。在此情况下 , 如果为用户代理声明多个特定组, | ||||||||||||||||||||||
| /*.php | 匹配包含 .php 的任何路径。 例如
,因此 Google 会暂时将服务器错误解读为网站完全禁止访问 。且无需进行网址编码 。
| ||||||||||||||||||||||
